[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [SLUG] Re: Problem following Debian (testing) upgrade



On Thu, 7 Jun 2001, Ken Caldwell wrote:

> something has happend to corrupt /lib/security/pam_env.so the following
> lines appear where I was trying to login to the newly created account.

> Jun 7 20:07:20 adler login[17328]: PAM unable to
> dlopen(/lib/security/pam_env.so)
> Jun 7 20:07:20 adler login[17328]: PAM [dlerror: /lib/security/pam_env.so:
> invalid ELF header]
> Jun 7 20:07:20 adler login[17328]: PAM adding faulty module:
> /lib/security/pam_env.so Jun 7
> 20:07:30 adler login[17328]: FAILED
> LOGIN (1) on `tty2' FOR `jan', Module is unknown
>
> It looks like I have either picked up a corrupted file or the hard drive
> is on the way out.

Looks like it.  Definite problems there somewhere.  Have you had a look at
the module to see if it's what it should be?  Could be that another
(unrelated) file has smashed itself into that one... possible FS corruption
or something.

At any rate, you can get it all happy again (assuming this is the only
corrupt module) by just removing it from all pam files.  I don't think
there's anything on a normal Debian box that's set by pam_env... hang on...
<ruffles through filesystem> Nope, all lines in /etc/security/pam_env.conf
are commented out here.  Check it on yours, but unless you've modified
something I'd assume it's the same.


-- 
-----------------------------------------------------------------------
#include <disclaimer.h>
Matthew Palmer
mjp16@nospam.ieee.uow.edu.au


-- 
SLUG - Sydney Linux User Group Mailing List - http://slug.org.au/
More Info: http://lists.slug.org.au/listinfo/slug